Debug a map?

Anything related to creating maps goes here

Debug a map?

Postby Qube » Sat Jul 23, 2016 5:19 pm

Is there any way to get the bugginess out of a map I'm working on? I copied and pasted a large section, and now I have an issue with ghost cities, as well as some strange terrain bugs.

The map is called Hyborea.
Qube
 
Posts: 24
Joined: Fri Feb 05, 2016 4:22 pm

Re: Debug a map?

Postby KGB » Sun Jul 24, 2016 1:44 am

I've encountered the same thing when doing a large cut-paste that included cities/sites/ruins etc.

There was no magic fix. My choices were to start from a prior save or manually fix each area where there were issues.

KGB

P.S. How do you know you have Ghost cities (is count at top > actual cities on map)?
KGB
 
Posts: 3021
Joined: Tue Feb 16, 2010 12:06 am

Re: Debug a map?

Postby Qube » Sun Jul 24, 2016 2:59 am

The city count is off, and cities appear randomly on the mini-map. I can't place terrain in these areas, and odd interactions occur with some types of terrain.

Oddly, the number of ghost cities is steadily increasing, and they spawn in areas of the map I haven't really worked on yet. Maybe they are at the borders of the big copy-paste? I'm not entirely certain.
Qube
 
Posts: 24
Joined: Fri Feb 05, 2016 4:22 pm

Re: Debug a map?

Postby KGB » Sun Jul 24, 2016 3:02 pm

That's way worse than what happened to me.

I hate to say it but you should probably go back to a prior version or you may be better off starting again.

If you do start again, one thing that can help is to open a 2nd map editor (brand new map) in another tab on the browser. You can then cut areas in the original map (the one that has a problem) and paste in the 2nd tab on a new map. Do it in smaller increments and you may get everything fixed.

KGB
KGB
 
Posts: 3021
Joined: Tue Feb 16, 2010 12:06 am

Re: Debug a map?

Postby Qube » Sun Jul 24, 2016 4:55 pm

Well... I only have the one (buggy) version saved. I'll try out the copy and paste method. Maybe erasing all the cities and sites first will help avoid further bug-outs. Thanks for the tip.
Qube
 
Posts: 24
Joined: Fri Feb 05, 2016 4:22 pm

Re: Debug a map?

Postby Qube » Sun Jul 24, 2016 5:30 pm

I can't seem to copy from one map and paste in another. Am I missing something?
Qube
 
Posts: 24
Joined: Fri Feb 05, 2016 4:22 pm

Re: Debug a map?

Postby KGB » Sun Jul 24, 2016 8:06 pm

My bad. I described it wrong.

1) Open your bad map in the editor.
2) Click an area to copy.
3) Create a new map (not in a new tab, just right over your bad map).
4) Paste the copied area in the new map (it remembers what you copied).
5) Save your new map.

Repeat above process only loading your new map instead of creating it in step 3.

You may want to try a complete copy (ie upper left / lower right corners) to the new map rather than do it multiple times for smaller areas. That may be enough to fix the Ghost issues. If not you'll have to do multiple copies of smaller sections.

KGB
KGB
 
Posts: 3021
Joined: Tue Feb 16, 2010 12:06 am

Re: Debug a map?

Postby Qube » Sun Jul 24, 2016 10:16 pm

Thanks for the clarification.

Sadly the map seems bugged on some fundamental level. The copy and paste functions are bugging out too. It is Only allowing me to copy certain sections, and then not actually copying all the tiles in sections it "works" on. Looks like I'm gonna have to start over.
Qube
 
Posts: 24
Joined: Fri Feb 05, 2016 4:22 pm


Return to Map making

Who is online

Users browsing this forum: No registered users and 1 guest

cron
Not able to open ./cache/data_global.php